Unofficial Vestel PVR Issue TrackerGoto: Unofficial Vestel PVR Information (UK)
Digihome discussion forum at Digital Spy
PVR discussion forum at AVForums

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0231T7300recordingpublic08 Jul 11 21:5017 Feb 12 16:51
ReporterFutaura 
Assigned ToAbdurrahman 
PriorityhighSeveritymajorReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version4.2 
Target VersionFixed in Version6.3 
Summary0231: Corruption and/or lost frames in recordings
DescriptionI spotted this problem in v3.8, and it is still present in v4.2, but it has taken me a while to try to pinpoint and document the issue. Rather than explain the problem, please watch the two attached video files recorded with my camera - playback.wmv is the playback of a recording on 5* - notice the apparent video corruption on the 5* ident animation after the BT sponsor sequence. Compare this to the exact same sequence in livetv.avi and you'll see it is perfectly smooth in that. I have also attached chunk.1 which is the raw recording data which I managed to transfer off the PVR using telnet/ftpput. I've checked this file on a PC and it does look like the problem is in the file, so a recording issue rather than a playback issue, unless there is some difference in the decoding when it comes to decoding live streams and streams off hdd.

So, in summary, the problem does not show up at all when watching live tv on the PVR, but it always shows up when playing back a recording of it (timeshifting too). Additionally, attempting to rewind through this part of the recording causes the rewind to pause and you have to press rewind a number of times to get over the corrupt (?) part of the stream. For some reason, the problem always shows up with the 5* ident animations which are shown between every programme and at the start and end of advert breaks, but it can happen on any channel and is usually noticable in regular programmes by minor glitches/stutters in the video (sound is usually ok, but sometimes skips a fraction of a second).

Incidentally, this problem does not show up with my T835 box - the 5* animation plays fine on live tv and from a recording.
TagsNo tags attached.
Attached Fileswmv file icon playback.wmv (1,034,664 bytes) 08 Jul 11 22:09
wmv file icon livetv.wmv (1,174,302 bytes) 08 Jul 11 22:10
zip file icon chunk.zip (15,356,661 bytes) 08 Jul 11 22:17
zip file icon t816_stream_2.zip (9,896,804 bytes) 05 Aug 11 17:49
zip file icon t7300_stream_2.zip (9,889,779 bytes) 05 Aug 11 17:50

- Relationships

-  Notes
User avatar (0350)
Futaura (administrator)
27 Jul 11 22:19
edited on: 27 Jul 11 22:20

While watching back recordings, I've noticed that the most major glitches tend to happen most often when the majority of the picture is static and only a small section of the video is changing - the visual affect is very similar to what happens in the simple example above. It affects pretty much all recordings at some point.

User avatar (0351)
Abdurrahman (developer)
29 Jul 11 11:30

This chunk.1 file is encrypted and I need an unencrypted stream. Can you supply or how can I decrypt the stream?
User avatar (0352)
Futaura (administrator)
29 Jul 11 11:57

Hmmm... you mananged to unzip the chunk.zip file ok, I presume? I've double-checked by downloading the attached file, and the chunk.1 file is playable both on my PC and PS3, so presumably not encrypted.
User avatar (0364)
Abdurrahman (developer)
05 Aug 11 14:25

can not be reproducable, need the real stream
User avatar (0367)
Futaura (administrator)
05 Aug 11 15:11

I've pretty much confirmed this isn't signal related now, with a direct connection from the T7300 to the masthead amp (usually, it is split passively to 4 outputs which I thought might possibly be a factor). I shall try to save the same stream on both the T7300 and T816, and shall hopefully be able to read the stream off the T816 HDD on my PC (which currently doesn't have SATA support, otherwise I would have used the T835 instead). I'm trying to find a quick way to reproduce the problem, so that I can save some small streams to demonstrate it easily.
User avatar (0369)
Futaura (administrator)
05 Aug 11 18:02
edited on: 05 Aug 11 18:16

Another sample is attached. t7300_stream_2.zip contains the recording files, with presumably corrupt stream, made on the t7300. And t816_stream_2.zip contains the recording files made on the t816 at the same time as the t7300 recording. When playing these streams, the point to look out for is the "CELEBRITY BIG BROTHER" text about halfway through - notice how the "B" in "BIG" leaves a trail in the t7300 stream, but is ok in the t816 stream. And just to be clear, the stream looked fine live on the t7300 - the problem is only present when playing back the recording.

User avatar (0480)
Futaura (administrator)
04 Jan 12 14:10

Was there a change made between v6.0 and v6.3 to fix this? I still saw the problem with v6.0, but I think the problem may have gone since I installed v6.3. I've just caught up with a lot of recordings that I made in early December after installing v6.3, and the 5* ident animations were all perfect. However, if it wasn't the software that changed, perhaps a transmission change is the reason.
User avatar (0483)
Futaura (administrator)
12 Jan 12 18:39

I'm now 100% convinced something changed in early December either in v6.3 or transmission related. I have a series recorded that spans digital switchover in November and up the end of December. With v6.3, the glitches in the recordings made with v6.0 (before and after DSO), are still present in playback. But, with new recordings made in December (after installing v6.3), I have not seen any glitches having played back 4 episodes already, and the glitches are present in all previous recordings.
User avatar (0484)
Futaura (administrator)
13 Jan 12 14:44

Ok, I'm now certain this must have been fixed in the software, as I have tested the older box that I have which is still running v4.9 and the glitches in recordings were immediately apparent after making a new recording. Recording at the same programme at the same time on the newer box with v6.3 revealed no issues at all. I even tried rewinding at 1x speed since the glitches (even if not really noticable, visually) causes the rewind playback to pause/freeze when encountered and there were no troubles there either with v6.3.

- Issue History
Date Modified Username Field Change
08 Jul 11 21:50 Futaura New Issue
08 Jul 11 22:09 Futaura File Added: playback.wmv
08 Jul 11 22:10 Futaura File Added: livetv.wmv
08 Jul 11 22:17 Futaura File Added: chunk.zip
08 Jul 11 22:19 Futaura Description Updated View Revisions
08 Jul 11 22:20 Futaura Description Updated View Revisions
08 Jul 11 22:43 Futaura Description Updated View Revisions
09 Jul 11 09:33 Futaura Description Updated View Revisions
09 Jul 11 22:43 Futaura Description Updated View Revisions
09 Jul 11 22:44 Futaura Priority normal => high
27 Jul 11 22:19 Futaura Note Added: 0350
27 Jul 11 22:20 Futaura Note Edited: 0350 View Revisions
28 Jul 11 06:39 Abdurrahman Status new => assigned
29 Jul 11 11:30 Abdurrahman Note Added: 0351
29 Jul 11 11:57 Futaura Note Added: 0352
05 Aug 11 14:25 Abdurrahman Note Added: 0364
05 Aug 11 14:25 Abdurrahman Reproducibility always => unable to reproduce
05 Aug 11 14:25 Abdurrahman Resolution open => unable to reproduce
05 Aug 11 15:11 Futaura Note Added: 0367
05 Aug 11 17:49 Futaura File Added: t816_stream_2.zip
05 Aug 11 17:50 Futaura File Added: t7300_stream_2.zip
05 Aug 11 18:02 Futaura Note Added: 0369
05 Aug 11 18:16 Futaura Note Edited: 0369 View Revisions
04 Jan 12 14:10 Futaura Note Added: 0480
12 Jan 12 18:39 Futaura Note Added: 0483
12 Jan 12 18:40 Futaura Assigned To => Abdurrahman
12 Jan 12 18:40 Futaura Status assigned => feedback
13 Jan 12 14:44 Futaura Note Added: 0484
13 Jan 12 14:44 Futaura Status feedback => assigned
13 Jan 12 14:44 Futaura Status assigned => resolved
13 Jan 12 14:44 Futaura Fixed in Version => 6.3
13 Jan 12 14:44 Futaura Resolution unable to reproduce => fixed
17 Feb 12 16:51 Futaura Status resolved => closed


MantisBT 1.2.19 [^]
Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker