Unofficial Vestel PVR Issue TrackerGoto: Unofficial Vestel PVR Information (UK)
Digihome discussion forum at Digital Spy
PVR discussion forum at AVForums

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0243T7300low powerpublic18 Jul 11 09:4320 Oct 11 18:06
ReporterFutaura 
Assigned ToAbdurrahman 
PrioritynormalSeveritymajorReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version4.2 
Target VersionFixed in Version5.5 
Summary0243: Unit wakes up from standby but doesn't shutdown properly
DescriptionI've only had this happen twice so far with v4.2, and since it has happened during the night sometime, I haven't been able to save a serial log yet to see if any errors are shown. What happens is that the unit wakes up, not to make a recording, but when it wakes up every 60 minutes, but it then does not shutdown fully. The front panel goes off, the red led is on, and it looks like it is in low power standby, but the HDD is still spinning. On turning the box on, it goes through the "Initialising disk" part, but on the whole it switches on my quicker so possibly the OS never stopped running. Switching the box off immediately allows it to enter low power mode normally with HDD shut off.
TagsNo tags attached.
Attached Files

- Relationships
related to 0239closedFutaura Unit wakes up from low power every 60 minutes 
related to 0256closedAbdurrahman Recording library completely erased/lost 

-  Notes
User avatar (0357)
Futaura (administrator)
01 Aug 11 15:04

I'll continue to monitor this one - I've also had this happen when switching the box off myself during general use, and in that case I think it was due to a bad timer, because it was waiting to record from this timer, but that timer had already passed (hadn't recorded either). This might be related I guess.
User avatar (0374)
Abdurrahman (developer)
08 Aug 11 07:12

please re-check with v4.7sw, I cant reproduce the problem.
Could you reproduce it with new kernel? I mean with last board I send you?
User avatar (0378)
Futaura (administrator)
08 Aug 11 19:13

I've not had this happen since using the new board and v4.5, so fingers crossed this has been fixed. If not, I'll reopen later should it happen again.
User avatar (0380)
Futaura (administrator)
10 Aug 11 09:09

This happened again with v4.7 on the new board for the first time last night. The box was on, with clock on front panel, and HDD running. The HDD was making all I can describe as a constant buzzing noise rather than typical disk seeking noise, but it is not so uncommon because my T835 also makes the same noise at times. I tried powering the box on the with remote and then off, but again it would not enter low power standby and the front panel stayed on. Next I tried turning it on and looking at the timer list in case there was an errant timer causing the box to stay on, but everything looked fine. Then when I switched it off with the remote it enter low power standby as normal.

Maybe it is related, but I have switched automatic update checks off, so I'm going to switch that back on to see if it makes any difference.
User avatar (0381)
Futaura (administrator)
11 Aug 11 17:51

This happened for a second time with v4.7 sometime today (I was at work) after a scheduled recording had occurred at 13:45-14:15. However, something disastrous occurred this time - my recordings library has been erased completely! When I came home, the front panel clock was on so I switched the box on and then turned it off - it all seemed normal and went into low power standby. Then I turned it on again and the "please wait while hard disk is initialised" message stayed on the 5 minutes or so. Then I went to the library to find that everything was gone except the recording that occurred earlier at 13:45.
User avatar (0385)
Futaura (administrator)
12 Aug 11 14:26

Again this morning I found the box had woken up from low power mode overnight and had not shutdown. I have automatic update checks enabled now, and obviously it hasn't helped.

One observation which may or may not be important is that when the box wakes up every 60 minutes from low power mode, it usually displays --:-- on the front panel before immediately shutting down. However, in the cases described here, the current real time is always displayed. Perhaps the software is deciding to enter normal standby mode instead of low power standby for some reason? Maybe adding some serial debug in the relevant code could help track the problem down? Obviously for this bug it is actually good that the box keeps waking up every 60 minutes - makes it more likely to happen.
User avatar (0405)
Futaura (administrator)
22 Aug 11 20:14

I've not had this happen at all with v4.9 yet, but I have a theory which I won't be able to test until next week, so it is probably not worth investigating this further for now...

Maybe it was fixed in v4.8 or v4.9, but I'm wondering whether it is related to having series timers that have expired (i.e. listed with an egg timer next to them). I don't have any such timers at the moment, but I will do on Monday (F1 and MotoGP series timers which are normally set every 14 days or longer).
User avatar (0408)
Futaura (administrator)
30 Aug 11 10:14
edited on: 30 Aug 11 10:15

Everything has been fine since installing v4.9, until last night. This morning I woke up to find the HDD still on, but the front panel off and red light on as if it was in low power standby. However, it wasn't and immediately switched on - I think this possibly caused the library to be erased as in 0256.

My hunch is that it is related to series timers having expired (egg timer icon in the timers list), since I did not have any of those until Thursday night. However, it did work fine the next few days. On Sunday I had a second expired timer listed (F1) as it isn't on for another 2 weeks. This isn't a conclusive theory yet, but I am going to try and set up as many timers as possible where the series ends so that I have lots of these expired timers in the hope that it'll make this problem more reproducable which would prove it is the timers that are the problem.

User avatar (0410)
Futaura (administrator)
03 Sep 11 09:46

This happened again last night, and this time I decided to telnet into the box before touching it at all. The application was still running, sda1 was mounted, but sda2 was not. This raises two possibilities - either sda2 was not mounted when the box woke and booted up, or it unmounted it when shutting down, and got stuck after that for some reason.
User avatar (0413)
Futaura (administrator)
07 Sep 11 08:08

(Un)fortunately, it looks like we can discount my theory that it was related to expired timers, since I have 8 of those right now, and this problem is still showing up as randomly as before and is not happening more often.
User avatar (0415)
Futaura (administrator)
07 Sep 11 18:08

For the first time in a long time this problem occurred while I was at home sitting more or less next to the box. Consequently, serial logging was on, and these two lines appeared when the box attempted to switch off:
[Wed Sep  7 16:24:03 2011] testtool > umount: cannot umount /mnt/sda1: Device or resource busy

[Wed Sep  7 16:24:08 2011] umount: cannot umount /mnt/sda2: Device or resource busy

When I telnetted to the box while it was in the stuck non-shutdown state, indeed sda1 and sda2 were still mounted. And interestingly, as I mentioned before, the drive was making constant buzzing noise rather than typical disk seeking noise or non-activity, but as soon as I performed a "ls -l" on sda2 the noise stopped. Everything was fine after switching on/off/on.
User avatar (0435)
Futaura (administrator)
06 Oct 11 23:23

Looks like this has been fixed in v5.5 (CFE v2.33) - having used it for 2 weeks now, I've yet to have this problem reoccur.

- Issue History
Date Modified Username Field Change
18 Jul 11 09:43 Futaura New Issue
18 Jul 11 09:43 Futaura Relationship added related to 0239
01 Aug 11 15:04 Futaura Note Added: 0357
08 Aug 11 07:12 Abdurrahman Note Added: 0374
08 Aug 11 07:12 Abdurrahman Reproducibility random => unable to reproduce
08 Aug 11 19:13 Futaura Note Added: 0378
08 Aug 11 19:13 Futaura Status new => resolved
08 Aug 11 19:13 Futaura Fixed in Version => 4.5
08 Aug 11 19:13 Futaura Resolution open => fixed
08 Aug 11 19:13 Futaura Assigned To => Futaura
10 Aug 11 09:09 Futaura Note Added: 0380
10 Aug 11 09:09 Futaura Status resolved => feedback
10 Aug 11 09:09 Futaura Resolution fixed => reopened
11 Aug 11 17:51 Futaura Note Added: 0381
11 Aug 11 17:51 Futaura Status feedback => assigned
11 Aug 11 17:56 Futaura Relationship added related to 0256
12 Aug 11 14:26 Futaura Note Added: 0385
22 Aug 11 20:14 Futaura Note Added: 0405
30 Aug 11 10:14 Futaura Note Added: 0408
30 Aug 11 10:15 Futaura Note Edited: 0408 View Revisions
03 Sep 11 09:46 Futaura Note Added: 0410
07 Sep 11 08:08 Futaura Note Added: 0413
07 Sep 11 18:00 Futaura Assigned To Futaura => Abdurrahman
07 Sep 11 18:08 Futaura Note Added: 0415
06 Oct 11 23:23 Futaura Note Added: 0435
06 Oct 11 23:23 Futaura Status assigned => resolved
06 Oct 11 23:23 Futaura Fixed in Version 4.5 => 5.5
06 Oct 11 23:23 Futaura Resolution reopened => fixed
20 Oct 11 18:06 Futaura Status resolved => closed
18 Apr 12 11:06 Futaura Relationship deleted related to 0313


MantisBT 1.2.19 [^]
Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker